Square Service Disruption
Incident Report for Schedulicity
Resolved
The issue has been resolved and all Square services are working as expected.
Posted Jul 20, 2021 - 14:07 MDT
Monitoring
Square is working to implement a solution for the performance issues experienced while placing online orders. While we don’t have an ETA for when this will be resolved, you can follow along with Square’s status page right here: https://www.issquareup.com/
Posted Jul 20, 2021 - 09:32 MDT
Investigating
Square is currently experiencing a service disruption which may affect Schedulicity Pay transactions with businesses using Square payment processing. Square is aware of the issue and is working towards a fix. Schedulicity will provide updates as we learn more.
Posted Jul 20, 2021 - 08:28 MDT
This incident affected: The Essentials (Auto Billing, Client Text Reminders, Multiple Locations, Package Management, Payment Plugin, Unlimited Bookings Plus with Schedulicity Pay), Advanced Options (Automated Marketing), Android, iOS, Live Chat, Website, and Notification Delivery (Email).