The update and its associated planned downtime is now complete.
Posted Feb 27, 2024 - 22:19 MST
Update
We are continuing to investigate this issue.
Posted Feb 27, 2024 - 20:03 MST
Investigating
We are performing a planned update to our web and backend affecting web and native applications. Users will experience downtime and errors during this planned 2-4 hour window.